Displayr is currently experiencing a service disruption in US regions

Incident Report for Displayr

Resolved

All systems are functioning as expected.
Posted Apr 17, 2026 - 19:00 UTC

Monitoring

Fix has been applied and we’re monitoring the situation to ensure services remain stable.
Posted Apr 17, 2026 - 17:47 UTC

Investigating

We’re working on a fix for customers in the US region.
Posted Apr 17, 2026 - 17:09 UTC
This incident affected: Displayr (app.displayr.com, displayr.com).