app.displayr.com is having intermittent outages

Incident Report for Displayr

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 14:00 UTC

Monitoring

A fix has been implemented; we are seeing recoveries across the system with reduced latencies. We are continuing to monitor.
Posted Dec 05, 2025 - 13:16 UTC

Investigating

We are currently investigating this issue, intermittent outages of app.displayr.com resulting in degraded performance and longer loading times, and frequent restarts.
Posted Dec 05, 2025 - 11:56 UTC
This incident affected: Displayr (app.displayr.com).