Displayr is currently experiencing a service degradation in US regions

Incident Report for Displayr

Resolved

We have applied mitigating changes and can confirm that Displayr is now operating normally across US regions.
Posted Apr 20, 2026 - 11:46 UTC

Investigating

We are currently experiencing a service degradation in US regions. Our team is aware and actively investigating. Updates to follow.
Posted Apr 20, 2026 - 11:00 UTC
This incident affected: Displayr (app.displayr.com).