R calculations in Canada and East US regions have degraded performance

Incident Report for Displayr

Resolved

We've implemented a fix across regions that has resolved the instability in R calculations. We'll continue to monitor.
Posted Oct 24, 2025 - 22:26 UTC

Update

East US has been reported to still have issues. Our engineers are currently working towards a solution.
Posted Oct 24, 2025 - 19:49 UTC

Update

Service has been restored for East US.
We are continuing to investigate this issue for Canada.
Posted Oct 24, 2025 - 19:28 UTC

Investigating

We are currently investigating the issue.
Posted Oct 24, 2025 - 13:44 UTC
This incident affected: Displayr (R Servers).