File uploads intermittently failing

Incident Report for Displayr

Resolved

This incident has now been resolved.
Posted Jul 07, 2025 - 08:26 UTC

Monitoring

Our team is actively monitoring the situation.
Posted Jul 07, 2025 - 00:49 UTC

Investigating

File uploads are intermittently failing due to an incident with one of our third-party providers filestack. Their incident status is reported here: https://status.filestack.com/.

Our team is actively monitoring the situation and working closely with the provider to resolve the problem as quickly as possible. We will provide updates as soon as we have more information.
Posted Jul 07, 2025 - 00:49 UTC
This incident affected: Displayr (File Uploads To Displayr).