Displayr is currently experiencing a service disruption in US regions

Incident Report for Displayr

Resolved

The issue has been successfully resolved. All systems are functioning as expected. Thank you for your patience and support throughout the process.
Posted Apr 17, 2026 - 17:04 UTC

Monitoring

A fix has been applied and we’re monitoring the situation to ensure services remain stable.
Posted Apr 17, 2026 - 16:49 UTC

Update

We’re working on a fix for customers in the US region.
Posted Apr 17, 2026 - 16:34 UTC

Investigating

We’ll share another update as soon as we have more information.
Posted Apr 17, 2026 - 16:17 UTC
This incident affected: Displayr (app.displayr.com, australiaeast.displayr.com, canadacentral.displayr.com, southeastasia.displayr.com, westeurope.displayr.com, displayr.com).