Users experiencing time-outs on the My Reports and Settings pages for accounts in Western Europe
Incident Report for Displayr
Resolved
Users should no loner experience time-outs on the My Reports and Settings pages.
Posted Jan 11, 2024 - 12:26 UTC
Investigating
We are investigating slowness in the loading of the My Reports and Settings pages, which lists the documents in an account, for users in Western Europe.
Posted Jan 11, 2024 - 10:15 UTC
This incident affected: Displayr (westeurope.displayr.com).