Service Disruption – Australia East

Incident Report for Displayr

Resolved

The issue has been resolved. We apologise for the inconvenience.
Posted May 26, 2026 - 06:52 UTC

Investigating

We are aware of an issue affecting the Australia East environment where users are seeing the message "System is being upgraded." We are currently investigating the cause.
Posted May 26, 2026 - 06:49 UTC
This incident affected: Displayr (australiaeast.displayr.com).