Displayr outage in Western Europe region
Incident Report for Displayr
Resolved
Displayr functionality is back to normal.
Posted Dec 19, 2023 - 09:51 UTC
Update
Displayr documents are loading for users in Western Europe again.
Posted Dec 19, 2023 - 09:28 UTC
Update
We are continuing to work on a fix for this issue.
Posted Dec 19, 2023 - 09:13 UTC
Identified
Users on Western Europe Displayr users are currently unable to access Displayr. The team is investigating now.
Posted Dec 19, 2023 - 09:13 UTC
This incident affected: Displayr (app.displayr.com).